aboutsummaryrefslogtreecommitdiff
path: root/src/qt/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-01-07 11:30:17 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2014-01-11 10:20:28 +0100
commit202d853bbea8ecb2164b9c9dc69e2129b45f05f8 (patch)
tree86b48c4d03a96ca3698962ac9baac5c2ab085483 /src/qt/Makefile.am
parent6a0e2376a14c77585888373099109d51a08bd74f (diff)
downloadbitcoin-202d853bbea8ecb2164b9c9dc69e2129b45f05f8.tar.xz
qt: Move initialization/shutdown to a thread
Move AppInit2 and Shutdown to a thread. This allows a more responsive splash screen, prevents 'process does not respond' messages from the window system and will allow for showing a user friendly window while shutting down.
Diffstat (limited to 'src/qt/Makefile.am')
-rw-r--r--src/qt/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/qt/Makefile.am b/src/qt/Makefile.am
index abd8a9f118..99fdecb03a 100644
--- a/src/qt/Makefile.am
+++ b/src/qt/Makefile.am
@@ -108,7 +108,7 @@ QT_MOC_CPP = moc_aboutdialog.cpp moc_addressbookpage.cpp \
BITCOIN_MM = macdockiconhandler.mm macnotificationhandler.mm
-QT_MOC = intro.moc overviewpage.moc rpcconsole.moc
+QT_MOC = intro.moc overviewpage.moc rpcconsole.moc bitcoin.moc
QT_QRC_CPP = qrc_bitcoin.cpp
QT_QRC = bitcoin.qrc