aboutsummaryrefslogtreecommitdiff
path: root/src/qt/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-01-11 09:14:06 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2014-01-11 09:15:03 +0100
commit6a0e2376a14c77585888373099109d51a08bd74f (patch)
treee4ac226f869351d475be7d1f26d005d0db3c42f7 /src/qt/Makefile.am
parent62e9d774966c9f4344f0356c59ddadcc5ff17212 (diff)
parent42cc96737ca05a3b539ce5d1a734a7a62407d31c (diff)
downloadbitcoin-6a0e2376a14c77585888373099109d51a08bd74f.tar.xz
Merge pull request #3346
42cc967 qt5: fix typo causing broken selection logic (Cory Fields) 371f3f6 qt5: fix --with-qt with no arguments (Cory Fields) 2691cbc qt5: Force macports default include path to be searched last (Cory Fields) 8b0f608 qt5: tests: Make sure static plugin symbols are pulled in (Cory Fields) 47ffb50 qt5: Use QT_SELECT for debian-based distros. (Cory Fields) 60dc589 qt5: Use the info gleaned from configure for plugin importing (Cory Fields) c8ba8ef qt5: split out qt config and add qt5 support (Cory Fields) c614bd7 qt5: fix a build issue with osx and qtdbus (Cory Fields) 328bdb1 qt5: Ensure correct link order (Cory Fields)
Diffstat (limited to 'src/qt/Makefile.am')
-rw-r--r--src/qt/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/qt/Makefile.am b/src/qt/Makefile.am
index 863274e80c..abd8a9f118 100644
--- a/src/qt/Makefile.am
+++ b/src/qt/Makefile.am
@@ -220,10 +220,10 @@ bitcoinstrings.cpp: FORCE
translate: bitcoinstrings.cpp $(QT_FORMS_UI) $(QT_FORMS_UI) $(BITCOIN_QT_CPP) $(BITCOIN_QT_H) $(BITCOIN_MM)
@test -n $(LUPDATE) || echo "lupdate is required for updating translations"
- @$(LUPDATE) $^ -locations relative -no-obsolete -ts locale/bitcoin_en.ts
+ @QT_SELECT=$(QT_SELECT) $(LUPDATE) $^ -locations relative -no-obsolete -ts locale/bitcoin_en.ts
$(QT_QRC_CPP): $(QT_QRC) $(QT_QM) $(QT_FORMS_H) $(RES_ICONS) $(RES_IMAGES) $(RES_MOVIES) $(PROTOBUF_H)
- @cd $(abs_srcdir); test -f $(RCC) && $(RCC) -name bitcoin -o $(abs_builddir)/$@ $< || \
+ @cd $(abs_srcdir); test -f $(RCC) && QT_SELECT=$(QT_SELECT) $(RCC) -name bitcoin -o $(abs_builddir)/$@ $< || \
echo error: could not build $@
$(SED) -i.bak -e '/^\*\*.*Created:/d' $@ && rm $@.bak
$(SED) -i.bak -e '/^\*\*.*by:/d' $@ && rm $@.bak