aboutsummaryrefslogtreecommitdiff
path: root/src/qt/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2013-09-14 11:51:40 -0400
committerCory Fields <cory-nospam-@coryfields.com>2013-09-14 11:51:44 -0400
commitf286aa1611c625e16fae7af83bd10f5607272c9d (patch)
tree09d1ad2142e88d80fdb58dfd1fb74fd2f88c7a29 /src/qt/Makefile.am
parent11a79680b174ec39d462925ea565a23aa8c147ad (diff)
downloadbitcoin-f286aa1611c625e16fae7af83bd10f5607272c9d.tar.xz
autotools: rearrange qt sources to make them more flexible
Add BITCOIN_MM QR_CPP and BITCOIN_CPP in order to better accomodate complicated targets. This is a no-op change.
Diffstat (limited to 'src/qt/Makefile.am')
-rw-r--r--src/qt/Makefile.am36
1 files changed, 20 insertions, 16 deletions
diff --git a/src/qt/Makefile.am b/src/qt/Makefile.am
index c6c4cb37a3..af8ebee6c6 100644
--- a/src/qt/Makefile.am
+++ b/src/qt/Makefile.am
@@ -53,6 +53,9 @@ QT_MOC_CPP = moc_aboutdialog.cpp moc_addressbookpage.cpp \
moc_transactiontablemodel.cpp moc_transactionview.cpp moc_walletframe.cpp \
moc_walletmodel.cpp moc_walletstack.cpp moc_walletview.cpp
+BITCOIN_MM = macdockiconhandler.mm macnotificationhandler.mm
+QR_CPP = qrcodedialog.cpp
+
QT_MOC = intro.moc overviewpage.moc rpcconsole.moc
QT_QRC_CPP = qrc_bitcoin.cpp
@@ -91,18 +94,9 @@ RES_ICONS = res/icons/bitcoin.png res/icons/address-book.png \
res/icons/qrcode.png res/icons/debugwindow.png res/icons/bitcoin.ico \
res/icons/bitcoin_testnet.ico
-RES_IMAGES = res/images/about.png res/images/splash.png \
- res/images/splash_testnet.png
-
-RES_MOVIES = res/movies/update_spinner.mng
-
-BITCOIN_RC = res/bitcoin-qt-res.rc
-
-libbitcoinqt_a_CPPFLAGS = $(AM_CPPFLAGS) $(QT_INCLUDES) \
- -I$(top_srcdir)/src/qt/forms $(QT_DBUS_INCLUDES)
-libbitcoinqt_a_SOURCES = aboutdialog.cpp addressbookpage.cpp \
+BITCOIN_QT_CPP = aboutdialog.cpp addressbookpage.cpp \
addresstablemodel.cpp askpassphrasedialog.cpp bitcoinaddressvalidator.cpp \
- bitcoinamountfield.cpp bitcoin.cpp bitcoingui.cpp bitcoinstrings.cpp \
+ bitcoinamountfield.cpp bitcoin.cpp bitcoingui.cpp \
bitcoinunits.cpp clientmodel.cpp csvmodelwriter.cpp editaddressdialog.cpp \
guiutil.cpp intro.cpp monitoreddatamapper.cpp notificator.cpp \
optionsdialog.cpp optionsmodel.cpp overviewpage.cpp paymentrequestplus.cpp \
@@ -111,9 +105,19 @@ libbitcoinqt_a_SOURCES = aboutdialog.cpp addressbookpage.cpp \
signverifymessagedialog.cpp splashscreen.cpp transactiondesc.cpp \
transactiondescdialog.cpp transactionfilterproxy.cpp transactionrecord.cpp \
transactiontablemodel.cpp transactionview.cpp walletframe.cpp \
- walletmodel.cpp walletmodeltransaction.cpp walletstack.cpp walletview.cpp \
- $(BITCOIN_QT_H) $(QT_FORMS_UI) $(QT_QRC) $(QT_TS) $(PROTOBUF_PROTO) \
- $(RES_ICONS) $(RES_IMAGES) $(RES_MOVIES)
+ walletmodel.cpp walletmodeltransaction.cpp walletstack.cpp walletview.cpp
+
+RES_IMAGES = res/images/about.png res/images/splash.png \
+ res/images/splash_testnet.png
+
+RES_MOVIES = res/movies/update_spinner.mng
+
+BITCOIN_RC = res/bitcoin-qt-res.rc
+
+libbitcoinqt_a_CPPFLAGS = $(AM_CPPFLAGS) $(QT_INCLUDES) \
+ -I$(top_srcdir)/src/qt/forms $(QT_DBUS_INCLUDES)
+libbitcoinqt_a_SOURCES = $(BITCOIN_QT_CPP) $(BITCOIN_QT_H) $(QT_FORMS_UI) \
+ $(QT_QRC) $(QT_TS) $(PROTOBUF_PROTO) $(RES_ICONS) $(RES_IMAGES) $(RES_MOVIES)
nodist_libbitcoinqt_a_SOURCES = $(QT_MOC_CPP) $(QT_MOC) $(PROTOBUF_CC) \
$(PROTOBUF_H) $(QT_QRC_CPP)
@@ -126,13 +130,13 @@ $(QT_MOC): $(PROTOBUF_H)
$(QT_MOC_CPP): $(PROTOBUF_H)
if TARGET_DARWIN
- libbitcoinqt_a_SOURCES += macdockiconhandler.mm macnotificationhandler.mm
+ libbitcoinqt_a_SOURCES += $(BITCOIN_MM)
endif
if TARGET_WINDOWS
libbitcoinqt_a_SOURCES += $(BITCOIN_RC)
endif
if USE_QRCODE
- libbitcoinqt_a_SOURCES += qrcodedialog.cpp
+ libbitcoinqt_a_SOURCES += $(QR_CPP)
endif
#