aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2021-12-08 10:38:10 +0100
committerMarcoFalke <falke.marco@gmail.com>2021-12-08 10:39:37 +0100
commitf6013265b7f22ce63f5e5fd8700c03d56cb000c8 (patch)
treead077d2e4194df3657e5557521feadef959a1c2a /src/Makefile.am
parent84d921e79c738c7959692a4e7a76327469e8cc50 (diff)
parentdce8c4c38111556ca480aa0e63c46b71f66b508f (diff)
downloadbitcoin-f6013265b7f22ce63f5e5fd8700c03d56cb000c8.tar.xz
Merge bitcoin/bitcoin#20295: rpc: getblockfrompeer
dce8c4c38111556ca480aa0e63c46b71f66b508f rpc: getblockfrompeer (Sjors Provoost) b884ababc29ce963826d8a4327ed6a5e629ff175 rpc: move Ensure* helpers to server_util.h (Sjors Provoost) Pull request description: This adds an RPC method to fetch a block directly from a peer. This can used to fetch stale blocks with lower proof of work that are normally ignored by the node (`headers-only` in `getchaintips`). Usage: ``` bitcoin-cli getblockfrompeer HASH peer_n ``` Closes #20155 Limitations: * you have to specify which peer to fetch the block from * the node must already have the header ACKs for top commit: jnewbery: ACK dce8c4c38111556ca480aa0e63c46b71f66b508f fjahr: re-ACK dce8c4c38111556ca480aa0e63c46b71f66b508f Tree-SHA512: 843ba2b7a308f640770d624d0aa3265fdc5c6ea48e8db32269b96a082b7420f7953d1d8d1ef2e6529392c7172dded9d15639fbc9c24e7bfa5cfb79e13a5498c8
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 36da079674..654b322d33 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -200,12 +200,12 @@ BITCOIN_CORE_H = \
rpc/blockchain.h \
rpc/client.h \
rpc/mining.h \
- rpc/net.h \
rpc/protocol.h \
rpc/rawtransaction_util.h \
rpc/register.h \
rpc/request.h \
rpc/server.h \
+ rpc/server_util.h \
rpc/util.h \
scheduler.h \
script/descriptor.h \
@@ -361,6 +361,7 @@ libbitcoin_server_a_SOURCES = \
rpc/net.cpp \
rpc/rawtransaction.cpp \
rpc/server.cpp \
+ rpc/server_util.cpp \
script/sigcache.cpp \
shutdown.cpp \
signet.cpp \