aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2021-09-21 11:37:03 -0400
committerCarl Dong <contact@carldong.me>2021-12-07 14:48:49 -0500
commitac4bf138b849a8544798f3891d6623803040c265 (patch)
tree7ae646405acf38322912da24a0838eaa2212c9dc /src/Makefile.am
parent15f2e33bb3d1ad3bc997f6a84956337f46495091 (diff)
downloadbitcoin-ac4bf138b849a8544798f3891d6623803040c265.tar.xz
node/caches: Extract cache calculation logic
I strongly recommend reviewing with the following git-diff flags: --color-moved=dimmed_zebra --color-moved-ws=allow-indentation-change [META] In a future commit, this function will be re-used in TestingSetup so that the behaviour matches across test and non-test init codepaths.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 880e6b5362..a7911c49b2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -174,6 +174,7 @@ BITCOIN_CORE_H = \
netbase.h \
netmessagemaker.h \
node/blockstorage.h \
+ node/caches.h \
node/chainstate.h \
node/coin.h \
node/coinstats.h \
@@ -340,6 +341,7 @@ libbitcoin_server_a_SOURCES = \
net.cpp \
net_processing.cpp \
node/blockstorage.cpp \
+ node/caches.cpp \
node/chainstate.cpp \
node/coin.cpp \
node/coinstats.cpp \