aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-08-10 13:36:33 +0100
committerfanquake <fanquake@gmail.com>2022-08-10 13:36:33 +0100
commitd8b26abed91c421e8517a2c9a60b57d988121b3a (patch)
tree2cee8c6d367c7704bc40b4fdb90a6e6cbf3b14c8 /src/Makefile.am
parentac59112a6a093e641ce2803260dd9de97b1cd961 (diff)
downloadbitcoin-d8b26abed91c421e8517a2c9a60b57d988121b3a.tar.xz
build: move raw rule into Makefile.am
The same rule is used by the tests and benchmarks to generate headers, and currently causes #25501. Just deduplicate the code into Makefile.am.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 576a448a0d..18c6c25b96 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1065,6 +1065,15 @@ nodist_libbitcoin_ipc_a_SOURCES = $(libbitcoin_ipc_mpgen_output)
CLEANFILES += $(libbitcoin_ipc_mpgen_output)
endif
+%.raw.h: %.raw
+ @$(MKDIR_P) $(@D)
+ @{ \
+ echo "static unsigned const char $(*F)_raw[] = {" && \
+ $(HEXDUMP) -v -e '8/1 "0x%02x, "' -e '"\n"' $< | $(SED) -e 's/0x ,//g' && \
+ echo "};"; \
+ } > "$@.new" && mv -f "$@.new" "$@"
+ @echo "Generated $@"
+
include Makefile.minisketch.include
include Makefile.crc32c.include