aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-11-16 15:51:19 +0800
committerfanquake <fanquake@gmail.com>2021-11-16 16:09:25 +0800
commitd0923098c69233414a9c284d707e31e2d4f91e8e (patch)
tree742b4cb0105b39ccc848652bb18c0665dd66ba35 /src/Makefile.am
parentcf63d635b168fe4166f56839101b4200f09e3844 (diff)
parentfaba1abe469833b2dad01bac4e4d8a4ebb4bc97a (diff)
downloadbitcoin-d0923098c69233414a9c284d707e31e2d4f91e8e.tar.xz
Merge bitcoin/bitcoin#23491: scripted-diff: Move minisketchwrapper to src/node
faba1abe469833b2dad01bac4e4d8a4ebb4bc97a Sort file list after rename (MarcoFalke) fa8f60e31102e1153ad1452fbced51e54487a3d4 scripted-diff: Move minisketchwrapper to src/node (MarcoFalke) Pull request description: The newly added wrapper is currently in the node library, but not placed in the node directory. While it is possible to use the wrapper outside of a node context (for example in a utility), it seems unlikely. Either way, I think the wrapper should either be moved to the util lib+dir or the node lib+dir, not something in-between. Also, fix incorrect comment `BITCOIN_DBWRAPPER_H`. ACKs for top commit: fanquake: ACK faba1abe469833b2dad01bac4e4d8a4ebb4bc97a. I saw the comment in #21515, however given there hasn't been any new activity there, I'm going to merge this now. Tree-SHA512: fccc0cfd1fee661152a1378587b96795ffb7a7eceb6d2c27ea5401993fd8b9c0a92579fdba61203917ae6565269cb28d0973464fb6201dabf72a5143495d3e77
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6cfd5a9050..25cd5c03d9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -167,7 +167,6 @@ BITCOIN_CORE_H = \
memusage.h \
merkleblock.h \
miner.h \
- minisketchwrapper.h \
net.h \
net_permissions.h \
net_processing.h \
@@ -179,6 +178,7 @@ BITCOIN_CORE_H = \
node/coin.h \
node/coinstats.h \
node/context.h \
+ node/minisketchwrapper.h \
node/psbt.h \
node/transaction.h \
node/ui_interface.h \
@@ -335,7 +335,6 @@ libbitcoin_server_a_SOURCES = \
init.cpp \
mapport.cpp \
miner.cpp \
- minisketchwrapper.cpp \
net.cpp \
net_processing.cpp \
node/blockstorage.cpp \
@@ -343,6 +342,7 @@ libbitcoin_server_a_SOURCES = \
node/coinstats.cpp \
node/context.cpp \
node/interfaces.cpp \
+ node/minisketchwrapper.cpp \
node/psbt.cpp \
node/transaction.cpp \
node/ui_interface.cpp \