aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2022-02-08 17:06:21 -0500
committerCarl Dong <contact@carldong.me>2022-04-26 16:30:53 -0400
commit83a0bb7cc9907dbe089409ed5a417277ed63ed95 (patch)
treecc0b1f9c7e9c92fd3740f38cd8db980136e18416 /src/Makefile.am
parentc1e16cb31f4d8edde8fea310011189b8b272cb07 (diff)
downloadbitcoin-83a0bb7cc9907dbe089409ed5a417277ed63ed95.tar.xz
build: Separate lib_LTLIBRARIES initialization
Set lib_LTLIBRARIES with '=' to an empty value at the top of the Makefile.am and append to it from the library-local block for readability. Here's the error you get if you don't set lib_LTLIBRARIES to be empty: error: lib_LTLIBRARIES must be set with '=' before using '+=' [META] In a subsequent commit, we're going to introduce a library and append it to lib_LTLIBRARIES in its local block, this makes things more readable.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1b15cd109c..d074e6314e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,7 +15,7 @@ AM_LIBTOOLFLAGS = --preserve-dup-deps
PTHREAD_FLAGS = $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
EXTRA_LIBRARIES =
-lib_LTLIBRARIES = $(LIBBITCOINCONSENSUS)
+lib_LTLIBRARIES =
noinst_LTLIBRARIES =
bin_PROGRAMS =
@@ -895,6 +895,8 @@ bitcoin_chainstate-clientversion.$(OBJEXT): obj/build.h
# bitcoinconsensus library #
if BUILD_BITCOIN_LIBS
+lib_LTLIBRARIES += $(LIBBITCOINCONSENSUS)
+
include_HEADERS = script/bitcoinconsensus.h
libbitcoinconsensus_la_SOURCES = support/cleanse.cpp $(crypto_libbitcoin_crypto_base_la_SOURCES) $(libbitcoin_consensus_a_SOURCES)