aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2022-02-16 17:51:57 -0500
committerCarl Dong <contact@carldong.me>2022-05-23 14:53:35 -0400
commit80970985c965f79b8c376c8a922497e385445dd8 (patch)
treeaaba582afbad36c40b8f57fad509c26993a8e453 /src/Makefile.am
parent35f73ce4b2efd7341fe55f77b334f27ad8aad090 (diff)
downloadbitcoin-80970985c965f79b8c376c8a922497e385445dd8.tar.xz
coinstats: Split node/coinstats.h to kernel/coinstats.h
Most of this commit is pure-move. After this change: - kernel/coinstats.h -> Contains declarations for: - enum class CoinStatsHashType - struct CCoinsStats - GetBogoSize(...) - TxOutSer(...) - ComputeUTXOStats(...) - node/coinstats.h -> Just GetUTXOStats, which will be removed as we change callers to directly use the hashing/indexing codepaths in future commits.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 005a91912c..ffbd5e9376 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -172,6 +172,7 @@ BITCOIN_CORE_H = \
interfaces/node.h \
interfaces/wallet.h \
kernel/chainstatemanager_opts.h \
+ kernel/coinstats.h \
key.h \
key_io.h \
logging.h \