aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter.wuille@gmail.com>2017-07-18 01:06:11 -0700
committerPieter Wuille <pieter.wuille@gmail.com>2017-07-20 09:03:53 -0700
commit6b8d872e5e2dd68a5229ec55f5261dae34ff9bdb (patch)
tree3ac15ca0584417ab467071a4c28132630093a922 /src/Makefile.am
parentfa9be909c945c3689591590ac19504aa53154c2f (diff)
downloadbitcoin-6b8d872e5e2dd68a5229ec55f5261dae34ff9bdb.tar.xz
Protect SSE4 code behind a compile-time flag
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 35bfeb466c..f7abab482e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -263,11 +263,14 @@ crypto_libbitcoin_crypto_a_SOURCES = \
crypto/sha1.cpp \
crypto/sha1.h \
crypto/sha256.cpp \
- crypto/sha256_sse4.cpp \
crypto/sha256.h \
crypto/sha512.cpp \
crypto/sha512.h
+if EXPERIMENTAL_ASM
+crypto_libbitcoin_crypto_a_SOURCES += crypto/sha256_sse4.cpp
+endif
+
# consensus: shared between all executables that validate any consensus rules.
libbitcoin_consensus_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES)
libbitcoin_consensus_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)