aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2022-03-15 21:52:29 -0400
committerCarl Dong <contact@carldong.me>2022-04-11 16:56:34 -0400
commit64caf944797bc35c3044fe5675389656f9511a41 (patch)
treefbeed237957a82107fc9349ec72eba7875f04934 /src/Makefile.am
parent1392e8e2d8cfe4115f0a152aca16ffe3f0f4573a (diff)
downloadbitcoin-64caf944797bc35c3044fe5675389656f9511a41.tar.xz
build: Remove vestigial LIBLEVELDB_SSE42
- LIBLEVELDB_SSE42_INT was defined, but never referenced anywhere - LIBLEVELDB_SSE42 is referenced, but never defined anywhere Apparently leveldb used to have platform-specific crc32 code before it got split off into a separate lib.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c089bed0c9..abcfda2a3f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -681,7 +681,6 @@ bitcoin_bin_ldadd = \
$(LIBBITCOIN_CONSENSUS) \
$(LIBBITCOIN_CRYPTO) \
$(LIBLEVELDB) \
- $(LIBLEVELDB_SSE42) \
$(LIBMEMENV) \
$(LIBSECP256K1)
@@ -868,7 +867,6 @@ bitcoin_chainstate_LDADD = \
$(LIBUNIVALUE) \
$(LIBSECP256K1) \
$(LIBLEVELDB) \
- $(LIBLEVELDB_SSE42) \
$(LIBMEMENV)
# Required for obj/build.h to be generated first.