aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJeff Garzik <jgarzik@bitpay.com>2014-08-18 10:36:21 -0400
committerJeff Garzik <jgarzik@bitpay.com>2014-08-18 10:36:21 -0400
commit3cceba7abb22133fcaea8d4f7aaed345f0e48009 (patch)
tree221d4da65869d4b5df0a9db20af9a9c2566d9621 /src/Makefile.am
parent9d26dc3b2973252cc4dbe0f46edb56bfcea1cb78 (diff)
downloadbitcoin-3cceba7abb22133fcaea8d4f7aaed345f0e48009.tar.xz
Univalue: Do not build JSON escape list at runtime
No need to waste startup time building something that can be done at compile time. This also resolves a clang++ warning originally reported in #4714, univalue/univalue_write.cpp:33:12: warning: array subscript is of type 'char escapes['"'] = "\\""; ^~~~ etc.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eda20ad296..1442c3d668 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -187,6 +187,7 @@ univalue_libbitcoin_univalue_a_SOURCES = \
univalue/univalue.cpp \
univalue/univalue_read.cpp \
univalue/univalue_write.cpp \
+ univalue/univalue_escapes.h \
univalue/univalue.h
# common: shared between bitcoind, and bitcoin-qt and non-server tools