aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2022-02-16 15:31:02 -0500
committerCarl Dong <contact@carldong.me>2022-05-23 14:53:31 -0400
commit35f73ce4b2efd7341fe55f77b334f27ad8aad090 (patch)
tree6c43c08e4c3da86c3dee3c1152bafb1435300a8c /src/Makefile.am
parentb7634fe02b6b030f5d62502c73db84ba9a276640 (diff)
downloadbitcoin-35f73ce4b2efd7341fe55f77b334f27ad8aad090.tar.xz
coinstats: Move hasher codepath to kernel/coinstats
As mentioned in a previous commit, the hashing codepath can now be moved to a separate file. This decouples callers that only rely on the hashing codepath from the indexing one. This is key for libbitcoinkernel, which needs to have the CoinsStats hashing codepath for AssumeUTXO, but does not wish to be coupled with indexes. Note that only the .cpp file is split in this commit, the header files will be split in a subsequent commit and the #includes to node/coinstats.h will be adjusted to only #include the necessary headers.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0fd15baed1..005a91912c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -357,6 +357,7 @@ libbitcoin_node_a_SOURCES = \
index/coinstatsindex.cpp \
index/txindex.cpp \
init.cpp \
+ kernel/coinstats.cpp \
mapport.cpp \
net.cpp \
netgroup.cpp \
@@ -873,6 +874,7 @@ libbitcoinkernel_la_SOURCES = \
index/base.cpp \
index/coinstatsindex.cpp \
init/common.cpp \
+ kernel/coinstats.cpp \
key.cpp \
logging.cpp \
node/blockstorage.cpp \