aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2022-02-10 16:08:07 -0500
committerCarl Dong <contact@carldong.me>2022-02-14 14:54:01 -0500
commit2c03cec2ff8cdbfd5da92bfb507d218e5c6435b0 (patch)
treea9d46ae389a94b398f581f6dbae671720979bfa1 /src/Makefile.am
parent095aa6ca37bf0bd5c5e221bab779978a99b2a34c (diff)
downloadbitcoin-2c03cec2ff8cdbfd5da92bfb507d218e5c6435b0.tar.xz
ci: Build bitcoin-chainstate
...to make sure that the linker errors that arise from coupling regressions are caught by CI. Adding to the "no wallet" ci job as suggested by MarcoFalke.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 95a76b4c9e..ac6524909a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -853,6 +853,10 @@ bitcoin_chainstate_LDADD = \
$(LIBLEVELDB) \
$(LIBLEVELDB_SSE42) \
$(LIBMEMENV)
+
+# Required for obj/build.h to be generated first.
+# More details: https://www.gnu.org/software/automake/manual/html_node/Built-Sources-Example.html
+bitcoin_chainstate-clientversion.$(OBJEXT): obj/build.h
#
# bitcoinconsensus library #