aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2021-11-26 09:03:34 +0100
committerMarcoFalke <falke.marco@gmail.com>2021-11-26 09:03:39 +0100
commit16d698cdcf3c4ef34bae4ccd616d0ddc4a7165d4 (patch)
treed9b271f70ca219972c29f35256934502482e944d /src/Makefile.am
parent14fe4dbd4c897ccd79fe70c33f75661bbc66ab66 (diff)
parentfa4e09924b11b0dc94e377005f86a83c09761265 (diff)
downloadbitcoin-16d698cdcf3c4ef34bae4ccd616d0ddc4a7165d4.tar.xz
Merge bitcoin/bitcoin#23517: scripted-diff: Move miner to src/node
fa4e09924b11b0dc94e377005f86a83c09761265 refactor: Replace validation.h include with forward-decl in miner.h (MarcoFalke) fa0739a7d398aea952a07b73ef565e7c2da75898 style: Sort file list after rename (MarcoFalke) fa53e3a58c94731a90514fe92fad365a49adb10c scripted-diff: Move miner to src/node (MarcoFalke) Pull request description: It is impossible to run the miner without a node (validation, chainstate, mempool, rpc, ...). Also, the module is in the node library. Thus, it should be moved to `src/node`. Also, replace the `validation.h` include in the header with a forward-declaration. ACKs for top commit: theStack: Code-review ACK fa4e09924b11b0dc94e377005f86a83c09761265 Tree-SHA512: 791e6caa5839d8dc83b0f58f3f49bc0a7e3c1710822e8a44dede254c87b6f7531a0586fb95e8a067c181457a3895ad6041718aa2a2fac64cfc136bf04bb851d5
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 05d7d09f13..9d79ee0e62 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -166,7 +166,6 @@ BITCOIN_CORE_H = \
mapport.h \
memusage.h \
merkleblock.h \
- miner.h \
net.h \
net_permissions.h \
net_processing.h \
@@ -178,6 +177,7 @@ BITCOIN_CORE_H = \
node/coin.h \
node/coinstats.h \
node/context.h \
+ node/miner.h \
node/minisketchwrapper.h \
node/psbt.h \
node/transaction.h \
@@ -335,7 +335,6 @@ libbitcoin_server_a_SOURCES = \
index/txindex.cpp \
init.cpp \
mapport.cpp \
- miner.cpp \
net.cpp \
net_processing.cpp \
node/blockstorage.cpp \
@@ -343,6 +342,7 @@ libbitcoin_server_a_SOURCES = \
node/coinstats.cpp \
node/context.cpp \
node/interfaces.cpp \
+ node/miner.cpp \
node/minisketchwrapper.cpp \
node/psbt.cpp \
node/transaction.cpp \