aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2022-03-01 16:14:12 -0500
committerCarl Dong <contact@carldong.me>2022-05-20 11:57:51 -0400
commit04c31c1295eb4ecd42afd54b8e353cbda93d83f0 (patch)
tree1c5cd792c0dd52d0dc79cf21ba0623c12fdcfb83 /src/Makefile.am
parentdbe45c34f8b4fd7d615f7e05ef1454798ef0c8ca (diff)
downloadbitcoin-04c31c1295eb4ecd42afd54b8e353cbda93d83f0.tar.xz
Add ChainstateManager::m_adjusted_time_callback
This decouples validation.cpp from netaddress.cpp (transitively, timedata.cpp, and asmap.cpp). This is important for libbitcoinkernel as: - There is no reason for the consensus engine to be coupled with netaddress, timedata, and asmap - Users of libbitcoinkernel can now easily supply their own std::function that provides the adjusted time. See the src/Makefile.am changes for some satisfying removals.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d421e8f89d..a0e793e42a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -877,7 +877,6 @@ libbitcoinkernel_la_SOURCES = \
init/common.cpp \
key.cpp \
logging.cpp \
- netaddress.cpp \
node/blockstorage.cpp \
node/chainstate.cpp \
node/coinstats.cpp \
@@ -906,11 +905,9 @@ libbitcoinkernel_la_SOURCES = \
support/lockedpool.cpp \
sync.cpp \
threadinterrupt.cpp \
- timedata.cpp \
txdb.cpp \
txmempool.cpp \
uint256.cpp \
- util/asmap.cpp \
util/bytevectorhash.cpp \
util/check.cpp \
util/getuniquepath.cpp \