aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2022-02-16 15:23:11 -0500
committerCarl Dong <contact@carldong.me>2022-05-23 14:53:35 -0400
commitf1006875665ffe8ff5da8185effe25b860743b4e (patch)
tree92c88cfc60bd57518ab19881791010a9ba3e9c4f /src/Makefile.am
parentfaa52387e8e4856445b1cfc9b5e072ce8f690f36 (diff)
downloadbitcoin-f1006875665ffe8ff5da8185effe25b860743b4e.tar.xz
kernel: Use ComputeUTXOStats in validation
This is the "fruit of our labor" for this patchset. ChainstateManager::PopulateAndValidateSnapshot can now directly call ComputeUTXOStats(...). Our consensus engine is now fully decoupled from all indices. See the src/Makefile.am for some satisfying removals.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ffbd5e9376..9b06199676 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -872,15 +872,12 @@ libbitcoinkernel_la_SOURCES = \
flatfile.cpp \
fs.cpp \
hash.cpp \
- index/base.cpp \
- index/coinstatsindex.cpp \
init/common.cpp \
kernel/coinstats.cpp \
key.cpp \
logging.cpp \
node/blockstorage.cpp \
node/chainstate.cpp \
- node/coinstats.cpp \
node/ui_interface.cpp \
policy/feerate.cpp \
policy/fees.cpp \