aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2021-09-20 16:12:18 -0400
committerCarl Dong <contact@carldong.me>2021-12-06 15:55:16 -0500
commitcb64af9635a9553e335f2dc0b1cca20c6bbd0933 (patch)
tree8ce04ae564f96bda6ace11434246f1afcd98fea4 /src/Makefile.am
parent786ffb3ae488061e13c02ad3fb34a5d2fc785b3d (diff)
downloadbitcoin-cb64af9635a9553e335f2dc0b1cca20c6bbd0933.tar.xz
node: Extract chainstate loading sequence
I strongly recommend reviewing with the following git-diff flags: --color-moved=dimmed_zebra --color-moved-ws=allow-indentation-change [META] This commit is intended to be as close to a move-only commit as possible, and lingering ugliness will be resolved in subsequent commits. A few variables that are passed in by value instead of by reference deserve explanation: - fReset and fReindexChainstate are both local variables in AppInitMain and are not modified in the sequence - fPruneMode, despite being a global, is only modified in AppInitParameterInteraction, long before LoadChainstate is called ---- [META] This semantic will change in a future commit named "node/chainstate: Decouple from stringy errors"
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 72f548c192..880e6b5362 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -174,6 +174,7 @@ BITCOIN_CORE_H = \
netbase.h \
netmessagemaker.h \
node/blockstorage.h \
+ node/chainstate.h \
node/coin.h \
node/coinstats.h \
node/context.h \
@@ -339,6 +340,7 @@ libbitcoin_server_a_SOURCES = \
net.cpp \
net_processing.cpp \
node/blockstorage.cpp \
+ node/chainstate.cpp \
node/coin.cpp \
node/coinstats.cpp \
node/context.cpp \