aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-09-16 14:53:41 +0100
committerfanquake <fanquake@gmail.com>2022-09-16 14:53:53 +0100
commita688ff9046a9df58a373086445ab5796cccf9dd3 (patch)
treebb977d3a71e110e19a74d9a6083fb00fc392de78 /src/Makefile.am
parent9fefd00d8e672c045c87538e7a6c72183cc0f2e6 (diff)
parenta10df7cf351e3947ba2d6cd1357d2c3348f8559a (diff)
downloadbitcoin-a688ff9046a9df58a373086445ab5796cccf9dd3.tar.xz
Merge bitcoin/bitcoin#26087: build: prune BOOST_CPPFLAGS from libbitcoin_zmq
a10df7cf351e3947ba2d6cd1357d2c3348f8559a build: prune BOOST_CPPFLAGS from libbitcoin_zmq (fanquake) Pull request description: Rather than including `validation.h`, which ultimately means needing boost via `txmempool.h`, include `primitives/block.h` for `CBlock`, and remove `validation.h`, as we can get `cs_main` from `node/blockstorage.h`. ACKs for top commit: theuni: Nice. ACK a10df7cf351e3947ba2d6cd1357d2c3348f8559a. hebasto: ACK a10df7cf351e3947ba2d6cd1357d2c3348f8559a, tested on Linux x86_64 using theuni's [patch](https://github.com/theuni/bitcoin/commit/e131d8f1e33baa9a9499d2e1a4a99b171566c5a5) with depends. Tree-SHA512: 792b6f9e7e7788d10333b4943609efbc798f3b187c324a0f2d5acbb2d44e3c67705dc54d698eb04c23e5af7b8b73a47f8e7974e819eac12f12ae62f28c807476
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1bb887af20..6364e00d1e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -439,7 +439,7 @@ libbitcoin_node_a_SOURCES += dummywallet.cpp
endif
if ENABLE_ZMQ
-libbitcoin_zmq_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES) $(BOOST_CPPFLAGS) $(ZMQ_CFLAGS)
+libbitcoin_zmq_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES) $(ZMQ_CFLAGS)
libbitcoin_zmq_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_zmq_a_SOURCES = \
zmq/zmqabstractnotifier.cpp \