aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRyan Ofsky <ryan@ofsky.org>2022-05-25 18:01:22 -0400
committerRyan Ofsky <ryan@ofsky.org>2022-05-25 18:01:22 -0400
commit44904aa632cbe0722a52f1907ae015f1c6338ddf (patch)
tree1070a70c0b91919b86defda8cb2a927258a49a60 /src/Makefile.am
parent6e1c16c1442ab30694a3668b45af5bfd532f1e12 (diff)
downloadbitcoin-44904aa632cbe0722a52f1907ae015f1c6338ddf.tar.xz
multiprocess build cleanup: comment on manual dependencies
Also move manual dependency closer to actual build target
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0f72182f23..96934bde7a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -330,7 +330,6 @@ obj/build.h: FORCE
"$(abs_top_srcdir)"
libbitcoin_util_a-clientversion.$(OBJEXT): obj/build.h
-ipc/capnp/libbitcoin_ipc_a-protocol.$(OBJEXT): $(libbitcoin_ipc_mpgen_input:=.h)
# server: shared between bitcoind and bitcoin-qt
# Contains code accessing mempool and chain state that is meant to be separated
@@ -1012,6 +1011,10 @@ libbitcoin_ipc_mpgen_input = \
EXTRA_DIST += $(libbitcoin_ipc_mpgen_input)
%.capnp:
+# Explicitly list dependencies on generated headers as described in
+# https://www.gnu.org/software/automake/manual/html_node/Built-Sources-Example.html#Recording-Dependencies-manually
+ipc/capnp/libbitcoin_ipc_a-protocol.$(OBJEXT): $(libbitcoin_ipc_mpgen_input:=.h)
+
if BUILD_MULTIPROCESS
LIBBITCOIN_IPC=libbitcoin_ipc.a
libbitcoin_ipc_a_SOURCES = \