aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorglozow <gzhao408@berkeley.edu>2021-02-11 09:50:42 -0800
committerglozow <gzhao408@berkeley.edu>2021-05-20 21:34:31 +0100
commitb88d77aec5e7bef5305a668d15031351c0548b4d (patch)
treef579f8c5ab082d4e928bd1e5d793572b4125c1cd /src/Makefile.am
parent249f43f3cc52b0ffdf2c47aad95ba9d195f6a45e (diff)
downloadbitcoin-b88d77aec5e7bef5305a668d15031351c0548b4d.tar.xz
[policy] Define packages
Define the Package type as an alias for a vector of transactions for now. Add PackageValidationResult, similar to TxValidationResult and BlockValidationResult for package-wide errors that cannot be reported within a single transaction result, such as having too many transactions in the package. We can update the concept of what a package is and have different logic for packages vs lists of transactions in the future, e.g. for package relay.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 770bb76226..579cd4e919 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -193,6 +193,7 @@ BITCOIN_CORE_H = \
outputtype.h \
policy/feerate.h \
policy/fees.h \
+ policy/packages.h \
policy/policy.h \
policy/rbf.h \
policy/settings.h \