aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2020-11-27 13:59:26 +0100
committerVasil Dimov <vd@FreeBSD.org>2021-03-01 18:19:37 +0100
commitc22daa2ecff1acd25426cd46f98f2587d1d324c3 (patch)
treef8fca7ea86ea24f19ef0d498c4ed4ef15a43feba /src/Makefile.am
parent5bac7e45e1d3a07115b5ff002d988438fcc92a53 (diff)
downloadbitcoin-c22daa2ecff1acd25426cd46f98f2587d1d324c3.tar.xz
net: implement the necessary parts of the I2P SAM protocol
Implement the following commands from the I2P SAM protocol: * HELLO: needed for all of the remaining ones * DEST GENERATE: to generate our private key and destination * NAMING LOOKUP: to convert .i2p addresses to destinations * SESSION CREATE: needed for STREAM CONNECT and STREAM ACCEPT * STREAM CONNECT: to make outgoing connections * STREAM ACCEPT: to accept incoming connections
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d6af3049e8..1c6d97b714 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -148,6 +148,7 @@ BITCOIN_CORE_H = \
fs.h \
httprpc.h \
httpserver.h \
+ i2p.h \
index/base.h \
index/blockfilterindex.h \
index/disktxpos.h \
@@ -315,6 +316,7 @@ libbitcoin_server_a_SOURCES = \
flatfile.cpp \
httprpc.cpp \
httpserver.cpp \
+ i2p.cpp \
index/base.cpp \
index/blockfilterindex.cpp \
index/txindex.cpp \