aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSjors Provoost <sjors@sprovoost.nl>2019-04-27 19:10:35 +0200
committerSjors Provoost <sjors@sprovoost.nl>2021-02-23 14:34:30 +0100
commit8cf543f96dcd6fdfac1367b9e2b1d7d51be8bb76 (patch)
treeb37cf68c9abcdc19550365706071618cceeb6e9b /src/Makefile.am
parentf7eb7ecc6750ab267a979d9268ce5b5d151c26de (diff)
downloadbitcoin-8cf543f96dcd6fdfac1367b9e2b1d7d51be8bb76.tar.xz
wallet: add -signer argument for external signer command
Create basic ExternalSigner class with contructor. A Signer(<cmd>) is added to CWallet on load if -signer=<cmd> is set.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 67efbbeae4..3b81056d25 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -265,6 +265,7 @@ BITCOIN_CORE_H = \
wallet/crypter.h \
wallet/db.h \
wallet/dump.h \
+ wallet/external_signer.h \
wallet/feebumper.h \
wallet/fees.h \
wallet/ismine.h \
@@ -379,6 +380,7 @@ libbitcoin_wallet_a_SOURCES = \
wallet/crypter.cpp \
wallet/db.cpp \
wallet/dump.cpp \
+ wallet/external_signer.cpp \
wallet/feebumper.cpp \
wallet/fees.cpp \
wallet/interfaces.cpp \