aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-03-10 14:31:10 +0800
committerfanquake <fanquake@gmail.com>2021-03-10 14:31:10 +0800
commit52f0be3a933225429b9b59b58de4fe54c2b20a02 (patch)
tree845655cb778ae48044cb06bc4f3d92e7d994cc0c /src/Makefile.am
parentbca5ee6f38f0ac89f0bb90d9e005b5bbd7c25b82 (diff)
downloadbitcoin-52f0be3a933225429b9b59b58de4fe54c2b20a02.tar.xz
compat: remove memcpy -> memmove backwards compatibility alias
In glib 2.13 memcpy was changed such that the way it copied bytes was reversed. This caused all sorts of issues for existing software, which depended on the existing behavior (when they should have been using memmove). See: https://sourceware.org/bugzilla/show_bug.cgi?id=12518 https://bugzilla.redhat.com/show_bug.cgi?id=638477 Now that we require glibc 2.17+ (#17538), we should be well clear of having to maintain our memcpy -> memmove aliasing, which was introduced in #4339.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 56f561a172..583779e865 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -553,7 +553,6 @@ libbitcoin_util_a_SOURCES = \
support/lockedpool.cpp \
chainparamsbase.cpp \
clientversion.cpp \
- compat/glibc_sanity.cpp \
compat/glibcxx_sanity.cpp \
compat/strnlen.cpp \
fs.cpp \