aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2013-09-08 02:44:12 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2014-01-18 19:54:50 +0000
commitf930341d8165a16ba3e7d3dc53a36a37dfddeb36 (patch)
treea9cf04e5dad815f6870df92bff05d7861ccf5c85 /src/Makefile.am
parent4a290b526cb064fd698ddb339f6da820d5a60d86 (diff)
downloadbitcoin-f930341d8165a16ba3e7d3dc53a36a37dfddeb36.tar.xz
configure: Internal changes to make building bitcoind and bitcoin-cli optional
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 846de05d10..f27f16ab91 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -10,7 +10,15 @@ if ENABLE_WALLET
noinst_LIBRARIES += libbitcoin_wallet.a
endif
-bin_PROGRAMS = bitcoind bitcoin-cli
+bin_PROGRAMS =
+
+if BUILD_BITCOIND
+ bin_PROGRAMS += bitcoind
+endif
+
+if BUILD_BITCOIN_CLI
+ bin_PROGRAMS += bitcoin-cli
+endif
SUBDIRS = . $(BUILD_QT) $(BUILD_TEST)
DIST_SUBDIRS = . qt test