aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Kraft <d@domob.eu>2018-07-17 12:51:23 +0200
committerDaniel Kraft <d@domob.eu>2020-09-07 10:56:22 +0200
commita3ffb6ebebd753cec294c91cef7c603a30cf217e (patch)
tree2c9924ca5ac65d2c742227eea19163dc4d73b6a7 /src/Makefile.am
parent7f2ad1b9acef4ccc1b3e1a9f551416235d95cbfd (diff)
downloadbitcoin-a3ffb6ebebd753cec294c91cef7c603a30cf217e.tar.xz
Replace zmqconfig.h by a simple zmqutil.
zmqconfig.h is currently not really needed anywhere, except that it declares zmqError (which is then defined in zmqnotificationinterface.cpp). Note in particular that there is no need to conditionally include zmq.h only if ZMQ is enabled, because the place in the core code where the ZMQ library itself is included (init.cpp) is conditional already on that. This commit removes zmqconfig.h and replaces it by a much simpler zmqutil.h library for zmqError. The definition of the function is moved to the matching (newly created) zmqutil.cpp.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 175501d4a6..61ae49df31 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -262,10 +262,10 @@ BITCOIN_CORE_H = \
walletinitinterface.h \
warnings.h \
zmq/zmqabstractnotifier.h \
- zmq/zmqconfig.h\
zmq/zmqnotificationinterface.h \
zmq/zmqpublishnotifier.h \
- zmq/zmqrpc.h
+ zmq/zmqrpc.h \
+ zmq/zmqutil.h
obj/build.h: FORCE
@@ -344,7 +344,8 @@ libbitcoin_zmq_a_SOURCES = \
zmq/zmqabstractnotifier.cpp \
zmq/zmqnotificationinterface.cpp \
zmq/zmqpublishnotifier.cpp \
- zmq/zmqrpc.cpp
+ zmq/zmqrpc.cpp \
+ zmq/zmqutil.cpp
endif