aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRussell Yanofsky <russ@yanofsky.org>2020-04-02 08:28:11 -0400
committerRussell Yanofsky <russ@yanofsky.org>2020-04-02 08:28:11 -0400
commit0660119ac372c2863d14060ac1bc9bc243771f94 (patch)
tree533a8cb84193e626ae3787fe4b7ccc7d165c5e3f /src/Makefile.am
parent5c1ba3a10a18c6edee20f27f3609ffbbbaa2e8f3 (diff)
downloadbitcoin-0660119ac372c2863d14060ac1bc9bc243771f94.tar.xz
Drop unintended bitcoin-tx dependency on libevent
Don't include util/url.cpp to libbitcoin_util.a when libevent isn't available. This fixes a compile error trying to build bitcoin-tx without libevent reported by Luke Dashjr in https://github.com/bitcoin/bitcoin/issues/18465 Fixes #18465
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8c927f330b..c38a87a1e4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -523,9 +523,12 @@ libbitcoin_util_a_SOURCES = \
util/strencodings.cpp \
util/string.cpp \
util/time.cpp \
- util/url.cpp \
$(BITCOIN_CORE_H)
+if USE_LIBEVENT
+libbitcoin_util_a_SOURCES += util/url.cpp
+endif
+
if GLIBC_BACK_COMPAT
libbitcoin_util_a_SOURCES += compat/glibc_compat.cpp
AM_LDFLAGS += $(COMPAT_LDFLAGS)