aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter@wuille.net>2020-09-20 21:17:29 -0700
committerPieter Wuille <pieter@wuille.net>2020-10-12 11:01:16 -0700
commitda3b8fde03f2e8060bb7ff3bff17175dab85f0cd (patch)
tree288a1e596a2e026b06a117d2a62db6c314df65e4 /src/Makefile.am
parent0b2abaa666d6f3331e3246ffd64dd47946e9dcdf (diff)
downloadbitcoin-da3b8fde03f2e8060bb7ff3bff17175dab85f0cd.tar.xz
Add txrequest module
This adds a new module (unused for now) which defines TxRequestTracker, a data structure that maintains all information about transaction requests, and coordinates requests.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index aa63b5f516..e29063889b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -215,6 +215,7 @@ BITCOIN_CORE_H = \
timedata.h \
torcontrol.h \
txdb.h \
+ txrequest.h \
txmempool.h \
undo.h \
util/asmap.h \
@@ -327,6 +328,7 @@ libbitcoin_server_a_SOURCES = \
timedata.cpp \
torcontrol.cpp \
txdb.cpp \
+ txrequest.cpp \
txmempool.cpp \
validation.cpp \
validationinterface.cpp \