aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2020-04-20 15:31:07 -0400
committerMarcoFalke <falke.marco@gmail.com>2020-04-20 15:32:41 -0400
commitc4c3f110eb93243fc8f740070240f50b0008f206 (patch)
tree31bb431b888dd063d39a2f0a56e8658ae3317234 /src/Makefile.am
parent56d2ff8a8fc52676a22163f804a9f1a5415b4b71 (diff)
parent69749fbe6a95f45eb7a695a5f89be87e55c91fb8 (diff)
downloadbitcoin-c4c3f110eb93243fc8f740070240f50b0008f206.tar.xz
Merge #18190: tests: Add fuzzing harness for Golomb-Rice coding (GolombRiceEncode/GolombRiceDecode)
69749fbe6a95f45eb7a695a5f89be87e55c91fb8 tests: Add fuzzing harness for Golomb-Rice coding (GolombRiceEncode/GolombRiceDecode) (practicalswift) Pull request description: Add fuzzing harness for Golomb-Rice coding (`GolombRiceEncode`/`GolombRiceDecode`). Test this PR using: ``` $ make distclean $ ./autogen.sh $ CC=clang CXX=clang++ ./configure --enable-fuzz \ --with-sanitizers=address,fuzzer,undefined $ make $ src/test/fuzz/golomb_rice … ``` Top commit has no ACKs. Tree-SHA512: 1b26512301b8c22ab3b804d9b9e4baf933f26f8c05e462d583863badcec7e694548a34849a0d7c4ff7d58b19f6338b51819976ecf642bc4659b04ef71182d748
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f15852ac66..627df97cad 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -215,6 +215,7 @@ BITCOIN_CORE_H = \
util/check.h \
util/error.h \
util/fees.h \
+ util/golombrice.h \
util/spanparsing.h \
util/system.h \
util/macros.h \