aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2019-10-10 12:32:57 -0400
committerMarcoFalke <falke.marco@gmail.com>2019-10-10 12:33:03 -0400
commitbefdef8aee899dcf7e40aa5ea4bc1b0256381cdc (patch)
tree565b2ab040d7ba97fcdbe79c2411911919f43e81 /src/Makefile.am
parent59f0687fea26a19bfb90a3f55c67ed4aa895bbbd (diff)
parentbb36372b8f2bd675313ae8553ceb61f28c2c1afd (diff)
downloadbitcoin-befdef8aee899dcf7e40aa5ea4bc1b0256381cdc.tar.xz
Merge #16887: Abstract out some of the descriptor Span-parsing helpers
bb36372b8f2bd675313ae8553ceb61f28c2c1afd test: add unit tests for Span-parsing helpers (Sebastian Falbesoner) 5e69aeec3f2a0fafd5e591b7222716f00145761d Add documenting comments to spanparsing.h (Pieter Wuille) 230d43fdbc41b356700b0d8a6984d69e00279ade Abstract out some of the descriptor Span-parsing helpers (Pieter Wuille) Pull request description: As suggested here: https://github.com/bitcoin/bitcoin/pull/16800#issuecomment-531605482. This moves the Span parsing functions out of the descriptor module, making them more easily usable for other parsers (in particular, in preparation for miniscript parsing). ACKs for top commit: MarcoFalke: ACK bb36372b8f2bd675313ae8553ceb61f28c2c1afd Tree-SHA512: b5c5c11a9bc3f0a1c2c4cfa22755654ecfb8d4b69da0dc1fb9f04e1556dc0f6ffd87ad153600963279ac465d587d7971b53d240ced802d12693682411ac73deb
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 84254e45d1..eec84122ae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -208,6 +208,7 @@ BITCOIN_CORE_H = \
util/bytevectorhash.h \
util/error.h \
util/fees.h \
+ util/spanparsing.h \
util/system.h \
util/macros.h \
util/memory.h \
@@ -505,6 +506,7 @@ libbitcoin_util_a_SOURCES = \
util/moneystr.cpp \
util/rbf.cpp \
util/threadnames.cpp \
+ util/spanparsing.cpp \
util/strencodings.cpp \
util/string.cpp \
util/time.cpp \