aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGleb Naumenko <naumenko.gs@gmail.com>2019-12-18 14:27:03 -0500
committerGleb Naumenko <naumenko.gs@gmail.com>2019-12-18 14:27:03 -0500
commit8feb4e4b667361bf23344149c01594abebd56fdb (patch)
treedec8069422964d91614770ee7966b8f58d9ee2bc /src/Makefile.am
parent89a1f7a250ef70ff2d65701564f1e24bb9280d90 (diff)
downloadbitcoin-8feb4e4b667361bf23344149c01594abebd56fdb.tar.xz
Add asmap utility which queries a mapping
The scripts for creating a compact IP->ASN mapping are here: https://github.com/sipa/asmap Co-authored-by: Pieter Wuille <pieter.wuille@gmail.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 27c87688b4..cf1a264805 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -210,6 +210,7 @@ BITCOIN_CORE_H = \
txmempool.h \
ui_interface.h \
undo.h \
+ util/asmap.h \
util/bip32.h \
util/bytevectorhash.h \
util/check.h \
@@ -510,6 +511,7 @@ libbitcoin_util_a_SOURCES = \
support/cleanse.cpp \
sync.cpp \
threadinterrupt.cpp \
+ util/asmap.cpp \
util/bip32.cpp \
util/bytevectorhash.cpp \
util/error.cpp \