aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJames O'Beirne <james.obeirne@gmail.com>2019-03-28 11:41:01 -0400
committerJames O'Beirne <james.obeirne@gmail.com>2019-08-27 11:51:56 -0400
commit8a3b2eb17572ca2131778d52cc25ec359470a90f (patch)
treec651ebf44320e96af435fcf180a11de3472e670c /src/Makefile.am
parentadff8fe32101b2c007a85415c3ec565a7f137252 (diff)
downloadbitcoin-8a3b2eb17572ca2131778d52cc25ec359470a90f.tar.xz
move-only: move coins statistics utils out of RPC
These procedures will later be used in the ChainstateManager to compute statistics (particularly a content hash) for UTXO sets coming in from snapshots.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 477b1300bc..8fc7f61d4b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -156,6 +156,7 @@ BITCOIN_CORE_H = \
netbase.h \
netmessagemaker.h \
node/coin.h \
+ node/coinstats.h \
node/psbt.h \
node/transaction.h \
noui.h \
@@ -278,6 +279,7 @@ libbitcoin_server_a_SOURCES = \
net.cpp \
net_processing.cpp \
node/coin.cpp \
+ node/coinstats.cpp \
node/psbt.cpp \
node/transaction.cpp \
noui.cpp \