aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-01-12 08:22:31 +0800
committerfanquake <fanquake@gmail.com>2020-01-12 08:49:40 +0800
commit831e1220bc151b1016412359775406b34cb8f52c (patch)
tree0d35a89df5035d53eea5110ecad83972e3c617a7 /src/Makefile.am
parente258ce792a4849927a6db51786732d71cbbb65fc (diff)
downloadbitcoin-831e1220bc151b1016412359775406b34cb8f52c.tar.xz
build: remove double LIBBITCOIN_SERVER linking
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5ae945ac69..3af54c65b2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -554,12 +554,9 @@ if TARGET_WINDOWS
bitcoind_SOURCES += bitcoind-res.rc
endif
-# Libraries below may be listed more than once to resolve circular dependencies (see
-# https://eli.thegreenplace.net/2013/07/09/library-order-in-static-linking#circular-dependency)
bitcoind_LDADD = \
$(LIBBITCOIN_SERVER) \
$(LIBBITCOIN_WALLET) \
- $(LIBBITCOIN_SERVER) \
$(LIBBITCOIN_COMMON) \
$(LIBUNIVALUE) \
$(LIBBITCOIN_UTIL) \