aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter.wuille@gmail.com>2019-04-06 08:51:41 -0700
committerPieter Wuille <pieter.wuille@gmail.com>2019-04-06 08:55:17 -0700
commite439aeb30c0439001a781c5979aec41e1fc2aa50 (patch)
tree653c8c3ef12cdcd6c44771c55b70f5244422039d /src/Makefile.am
parent35991b162fd142d76d83e672002846c8a40eb794 (diff)
parent892eff05f115c0b002d0e0b6ffc3ab418480d25c (diff)
downloadbitcoin-e439aeb30c0439001a781c5979aec41e1fc2aa50.tar.xz
Merge #15508: Refactor analyzepsbt for use outside RPC code
892eff05f1 Add documentation of struct PSBTAnalysis et al (Glenn Willen) ef22fe8c1f Refactor analyzepsbt for use outside RPC code (Glenn Willen) afd20a25f2 Move PSBT decoding functions from core_io to psbt.cpp (Glenn Willen) Pull request description: Refactor the analyzepsbt RPC into (1) an AnalyzePSBT function, which returns its output as a new strongly-typed PSBTAnalysis struct, and (2) a thin wrapper which converts the struct into a UniValue for RPC use. ---- As with my previous refactoring PR, I need this because I am creating a dependency on this code from the GUI. Per discussion in #bitcoin-core-dev on IRC, since we don't want to create a dependency on UniValue in anything outside RPC, I introduced some new structs to hold the info we get when analyzing a PSBT. For the field types, I used whatever types are already used internally for this data (e.g. CAmount, CFeeRate, CKeyID), and only convert to int/string etc. in the wrapper. @achow101, maybe take the first look? :-) ACKs for commit 892eff: sipa: utACK 892eff05f115c0b002d0e0b6ffc3ab418480d25c achow101: utACK 892eff05f115c0b002d0e0b6ffc3ab418480d25c ryanofsky: utACK 892eff05f115c0b002d0e0b6ffc3ab418480d25c. Just small cleanups since the last review: removing unneeded include, forward decl, adding const ref Tree-SHA512: eb278b0a82717ebc3eb0c08dc5bb4eefb996a317a6a3a8ecf51cd88110ddbb188ad3482cdd9563e557995e73aca5a282c1f6e352bc598155f1203b7b46fe5dee
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8f0110b43e..0385c825ea 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -434,8 +434,8 @@ libbitcoin_common_a_SOURCES = \
netaddress.cpp \
netbase.cpp \
policy/feerate.cpp \
- psbt.cpp \
protocol.cpp \
+ psbt.cpp \
scheduler.cpp \
script/descriptor.cpp \
script/ismine.cpp \