aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRussell Yanofsky <russ@yanofsky.org>2019-04-08 16:33:05 -0400
committerRussell Yanofsky <russ@yanofsky.org>2019-04-09 17:53:08 -0400
commit4d074e84a2cf419510e2920417799f62747f4b07 (patch)
tree545a1e6e757086c1e29becb5e202422f1a40688b /src/Makefile.am
parentfd509bd1f71df628b933ea7a135a9a957a5e0136 (diff)
downloadbitcoin-4d074e84a2cf419510e2920417799f62747f4b07.tar.xz
[build] Move AnalyzePSBT from psbt.cpp to node/psbt.cpp
psbt.cpp definitions except for AnalyzePSBT are used by the wallet and need to be linked into the wallet binary. AnalyzePSBT is an exception in that it is not used by the wallet, and depends on node classes like CCoinsViewCache, and on node global variables like nBytesPerSigOp. So AnalyzePSBT is more at home in libbitcoin_server than libbitcoin_common, and in any case needs to be defined in a separate object file than other PSBT utilities, to avoid dragging link dependencies on node functions and global variables into the wallet.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 17e72a7906..cb0604391e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -156,6 +156,7 @@ BITCOIN_CORE_H = \
netbase.h \
netmessagemaker.h \
node/coin.h \
+ node/psbt.h \
node/transaction.h \
noui.h \
optional.h \
@@ -272,6 +273,7 @@ libbitcoin_server_a_SOURCES = \
net.cpp \
net_processing.cpp \
node/coin.cpp \
+ node/psbt.cpp \
node/transaction.cpp \
noui.cpp \
policy/fees.cpp \