aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPeter Bushnell <bushsolo@gmail.com>2019-03-28 07:16:42 +0000
committerPeter Bushnell <bushsolo@gmail.com>2019-03-28 15:31:42 +0000
commit2a1408c3ec036d9f89c4241689cd16f26093b209 (patch)
tree0906fae87ac3a3559cd87f4497f9d90543e2e453 /src/Makefile.am
parentedb8df4fea13dadd5691ea0a52a0271269b4d1f6 (diff)
downloadbitcoin-2a1408c3ec036d9f89c4241689cd16f26093b209.tar.xz
Comment for seemingly duplicate LIBBITCOIN_SERVER
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bef2c10636..8f0110b43e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -497,6 +497,8 @@ if TARGET_WINDOWS
bitcoind_SOURCES += bitcoind-res.rc
endif
+# Libraries below may be listed more than once to resolve circular dependencies (see
+# https://eli.thegreenplace.net/2013/07/09/library-order-in-static-linking#circular-dependency)
bitcoind_LDADD = \
$(LIBBITCOIN_SERVER) \
$(LIBBITCOIN_WALLET) \