aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Kraft <d@domob.eu>2019-07-22 14:26:18 +0200
committerDaniel Kraft <d@domob.eu>2019-07-22 14:26:18 +0200
commit29ee4c417d97dca29c4ef53b6c1a55caa902787a (patch)
treee138b8c919df9437b0cb35c52392fe94b079666d /src/Makefile.am
parent51a6e2c4192913c9c18507d8dfb3302500b26cc3 (diff)
downloadbitcoin-29ee4c417d97dca29c4ef53b6c1a55caa902787a.tar.xz
Specify AM_CPPFLAGS for ZMQ.
When building the ZMQ static library, add AM_CPPFLAGS to the library CPPFLAGS. Otherwise, we may miss important flags that are specified elsewhere. For instance, if --enable-debug is passed and -DDEBUG_LOCKORDER set, then that would not apply to the ZMQ library before (causing potential for hard-to-find bugs).
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0ed412295f..ffa2980d59 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -309,7 +309,7 @@ libbitcoin_server_a_SOURCES += dummywallet.cpp
endif
if ENABLE_ZMQ
-libbitcoin_zmq_a_CPPFLAGS = $(BITCOIN_INCLUDES) $(ZMQ_CFLAGS)
+libbitcoin_zmq_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES) $(ZMQ_CFLAGS)
libbitcoin_zmq_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_zmq_a_SOURCES = \
zmq/zmqabstractnotifier.cpp \