aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJohn Newbery <john@johnnewbery.com>2019-04-02 17:14:35 -0400
committerJohn Newbery <john@johnnewbery.com>2019-04-09 17:53:08 -0400
commitfd509bd1f71df628b933ea7a135a9a957a5e0136 (patch)
treec9e056e1ad1897f6ad33ce5b0b9a6d754ce6afc6 /src/Makefile.am
parent9eaeb7fb8d4ab0d4493849e6c17e314fd75fea9c (diff)
downloadbitcoin-fd509bd1f71df628b933ea7a135a9a957a5e0136.tar.xz
[docs] Document src subdirectories and different libraries
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7849e4740b..17e72a7906 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -245,6 +245,9 @@ obj/build.h: FORCE
libbitcoin_util_a-clientversion.$(OBJEXT): obj/build.h
# server: shared between bitcoind and bitcoin-qt
+# Contains code accessing mempool and chain state that is meant to be separated
+# from wallet and gui code (see node/README.md). Shared code should go in
+# libbitcoin_common or libbitcoin_util libraries, instead.
libbitcoin_server_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES) $(MINIUPNPC_CPPFLAGS) $(EVENT_CFLAGS) $(EVENT_PTHREADS_CFLAGS)
libbitcoin_server_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_server_a_SOURCES = \