aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJames O'Beirne <james.obeirne@gmail.com>2018-06-13 14:50:59 -0400
committerJames O'Beirne <james.obeirne@gmail.com>2019-04-29 13:42:25 -0400
commitae5f2b6a6cc7b2260e9dff99c1bf378922e0e988 (patch)
tree6646e4d0936dc2217a10b3972fb9250f5beaadc9 /src/Makefile.am
parent188ca75e5fe4837d16241446558c7566912f67b2 (diff)
downloadbitcoin-ae5f2b6a6cc7b2260e9dff99c1bf378922e0e988.tar.xz
threads: introduce util/threadnames, refactor thread naming
This work is prerequisite to attaching thread names to log lines and deadlock debug utilities. This code allows setting of an "internal" threadname per thread on platforms where thread_local is available. This commit also moves RenameThread() out of a more general module and adds a numeric suffix to disambiguate between threads with the same name. It explicitly names a few main threads using the new util::ThreadRename().
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 059ed18134..0fefa34cd8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -210,6 +210,7 @@ BITCOIN_CORE_H = \
util/memory.h \
util/moneystr.h \
util/rbf.h \
+ util/threadnames.h \
util/time.h \
util/url.h \
util/validation.h \
@@ -491,6 +492,7 @@ libbitcoin_util_a_SOURCES = \
util/system.cpp \
util/moneystr.cpp \
util/rbf.cpp \
+ util/threadnames.cpp \
util/strencodings.cpp \
util/time.cpp \
util/url.cpp \