aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJohn Newbery <john@johnnewbery.com>2019-04-02 14:14:58 -0400
committerJohn Newbery <john@johnnewbery.com>2019-04-09 17:53:08 -0400
commit4a75c9d6512a5580e60104103ea11d2cd9586354 (patch)
tree03928bbefeff422d8be4fa400c88be34c1150328 /src/Makefile.am
parentfdf8888b6f0c63e8a4cb1459752625e642d6a4dd (diff)
downloadbitcoin-4a75c9d6512a5580e60104103ea11d2cd9586354.tar.xz
[build] Move policy settings to new src/policy/settings unit
This moves the following policy settings functions and globals to a new src/policy/settings unit in lib_server: - `incrementalRelayFee` - `dustRelayFee` - `nBytesPerSigOp` - `fIsBareMultisigStd` These settings are only required by the node and should not be accessed by other libraries.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cb0745835a..c07e268863 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -164,6 +164,7 @@ BITCOIN_CORE_H = \
policy/fees.h \
policy/policy.h \
policy/rbf.h \
+ policy/settings.h \
pow.h \
protocol.h \
psbt.h \
@@ -269,8 +270,8 @@ libbitcoin_server_a_SOURCES = \
noui.cpp \
outputtype.cpp \
policy/fees.cpp \
- policy/policy.cpp \
policy/rbf.cpp \
+ policy/settings.cpp \
pow.cpp \
rest.cpp \
rpc/blockchain.cpp \
@@ -436,6 +437,7 @@ libbitcoin_common_a_SOURCES = \
netaddress.cpp \
netbase.cpp \
policy/feerate.cpp \
+ policy/policy.cpp \
protocol.cpp \
psbt.cpp \
scheduler.cpp \