aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2019-07-30 15:37:24 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2019-07-30 15:42:05 +0200
commitbd35ec36f5d6b4e65e886eaf24f8985d86f85753 (patch)
treeb964682257b28d2d7eb2374cb5211fe0d5d9747c /src/Makefile.am
parent53b5a4f7eca9a445266de0f0dc127a76dd36e25d (diff)
parent29ee4c417d97dca29c4ef53b6c1a55caa902787a (diff)
downloadbitcoin-bd35ec36f5d6b4e65e886eaf24f8985d86f85753.tar.xz
Merge #16434: build: Specify AM_CPPFLAGS for ZMQ
29ee4c417d97dca29c4ef53b6c1a55caa902787a Specify AM_CPPFLAGS for ZMQ. (Daniel Kraft) Pull request description: When building the ZMQ static library, add `AM_CPPFLAGS` to the library `CPPFLAGS`. Otherwise, we may miss important flags that are specified elsewhere. For instance, if `--enable-debug` is passed and `-DDEBUG_LOCKORDER` set, then that would not apply to the ZMQ library before (causing potential for hard-to-find bugs). ACKs for top commit: laanwj: utACK 29ee4c417d97dca29c4ef53b6c1a55caa902787a Tree-SHA512: 64085d71ed3f435a6e4df6dc42bda8b6159a4d292d0547c5b38c09d6ac95e976ad1728cd65278bffdd57363f60a58eb762b1171dafbe055cf94ffcd4f66da877
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0f05439227..ef5b1900d9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -310,7 +310,7 @@ libbitcoin_server_a_SOURCES += dummywallet.cpp
endif
if ENABLE_ZMQ
-libbitcoin_zmq_a_CPPFLAGS = $(BITCOIN_INCLUDES) $(ZMQ_CFLAGS)
+libbitcoin_zmq_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES) $(ZMQ_CFLAGS)
libbitcoin_zmq_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_zmq_a_SOURCES = \
zmq/zmqabstractnotifier.cpp \