aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKarl-Johan Alm <karljohan-alm@garage.co.jp>2019-06-20 02:39:38 +0900
committerKarl-Johan Alm <karljohan-alm@garage.co.jp>2019-07-05 11:22:02 +0900
commit5c5e32bbe3dfa790dd8bb421fbd6301ae10b09f5 (patch)
tree8dcdcbeae96f2a7fb03b36bfa50d269b6bc68749 /src/Makefile.am
parent0ab8ba1ac65b70f044a5e323b13d098cef33695a (diff)
downloadbitcoin-5c5e32bbe3dfa790dd8bb421fbd6301ae10b09f5.tar.xz
rpc: migrate JSONRPCRequest functionality into request.cpp
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 39e8d3d689..e4c542fa25 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -175,9 +175,10 @@ BITCOIN_CORE_H = \
rpc/blockchain.h \
rpc/client.h \
rpc/protocol.h \
- rpc/server.h \
rpc/rawtransaction_util.h \
rpc/register.h \
+ rpc/request.h \
+ rpc/server.h \
rpc/util.h \
scheduler.h \
script/descriptor.h \
@@ -481,7 +482,7 @@ libbitcoin_util_a_SOURCES = \
interfaces/handler.cpp \
logging.cpp \
random.cpp \
- rpc/protocol.cpp \
+ rpc/request.cpp \
support/cleanse.cpp \
sync.cpp \
threadinterrupt.cpp \