aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <accounts@carldong.me>2019-03-11 13:41:00 -0400
committerCarl Dong <accounts@carldong.me>2019-03-18 11:05:17 -0400
commit340ef50772a6a7dfcb1d38a35b8b9f54726c7b36 (patch)
tree007144c36ec34e2776e7246826f7f4f55ca679e5 /src/Makefile.am
parent7ec7aea442815eef38068b3f16527129c341b000 (diff)
downloadbitcoin-340ef50772a6a7dfcb1d38a35b8b9f54726c7b36.tar.xz
depends: Defer to Python detected by autoconf
Since autoconf already detects the correct python binary path, we should use that instead of going around it. Also has the benefit of working in extremely restricted environments where /usr/bin/env might not be available.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 14db963253..da96a1d96a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -642,13 +642,13 @@ clean-local:
check-symbols: $(bin_PROGRAMS)
if GLIBC_BACK_COMPAT
@echo "Checking glibc back compat..."
- $(AM_V_at) READELF=$(READELF) CPPFILT=$(CPPFILT) $(top_srcdir)/contrib/devtools/symbol-check.py < $(bin_PROGRAMS)
+ $(AM_V_at) READELF=$(READELF) CPPFILT=$(CPPFILT) $(PYTHON) $(top_srcdir)/contrib/devtools/symbol-check.py < $(bin_PROGRAMS)
endif
check-security: $(bin_PROGRAMS)
if HARDEN
@echo "Checking binary security..."
- $(AM_V_at) READELF=$(READELF) OBJDUMP=$(OBJDUMP) $(top_srcdir)/contrib/devtools/security-check.py < $(bin_PROGRAMS)
+ $(AM_V_at) READELF=$(READELF) OBJDUMP=$(OBJDUMP) $(PYTHON) $(top_srcdir)/contrib/devtools/security-check.py < $(bin_PROGRAMS)
endif
if ENABLE_BIP70