aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJohn Newbery <john@johnnewbery.com>2019-04-02 16:42:51 -0400
committerJohn Newbery <john@johnnewbery.com>2019-04-09 17:53:08 -0400
commit1acc61f8746bc6efb905e121a9f607c4f5982b35 (patch)
tree0b332f29a18351a6bbe7d8536890a7f7894178f8 /src/Makefile.am
parent4a75c9d6512a5580e60104103ea11d2cd9586354 (diff)
downloadbitcoin-1acc61f8746bc6efb905e121a9f607c4f5982b35.tar.xz
[build] Move rpc utility methods to rpc/util
Moves the following utility methods to rpc/util and moves that unit to libbitcoin_common so they can be accessed by all libraries. - `RPCTypeCheck` - `RPCTypeCheckArgument` - `RPCTypeCheckObj` - `AmountFromValue` - `ParseHashV``ParseHashO` - `ParseHexV` - `ParseHexO` - `HelpExampleCli` - `HelpExampleRpc`
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c07e268863..cbbf35ccb9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -280,7 +280,6 @@ libbitcoin_server_a_SOURCES = \
rpc/net.cpp \
rpc/rawtransaction.cpp \
rpc/server.cpp \
- rpc/util.cpp \
script/sigcache.cpp \
shutdown.cpp \
timedata.cpp \
@@ -440,6 +439,7 @@ libbitcoin_common_a_SOURCES = \
policy/policy.cpp \
protocol.cpp \
psbt.cpp \
+ rpc/util.cpp \
scheduler.cpp \
script/descriptor.cpp \
script/ismine.cpp \