aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2018-09-12 09:35:41 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2018-09-12 09:35:41 +0200
commite0664f7f54aa9cf99ba31ca4bd9de1db0a9310a4 (patch)
tree02ca99af0ce8fa9c2b7c6649df18f58616e1f026 /src/Makefile.am
parent4103cc31690e5be21854a9628f57c54b880ee195 (diff)
downloadbitcoin-e0664f7f54aa9cf99ba31ca4bd9de1db0a9310a4.tar.xz
build: Move interfaces/* to libbitcoin_server
These are shared between bitcoind and bitcoin-qt. It is unnecessary for them to be linked against the other utilities.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 74855dd7a5..159812e847 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -228,6 +228,8 @@ libbitcoin_server_a_SOURCES = \
httpserver.cpp \
index/base.cpp \
index/txindex.cpp \
+ interfaces/handler.cpp \
+ interfaces/node.cpp \
init.cpp \
dbwrapper.cpp \
merkleblock.cpp \
@@ -414,8 +416,6 @@ libbitcoin_util_a_SOURCES = \
compat/glibcxx_sanity.cpp \
compat/strnlen.cpp \
fs.cpp \
- interfaces/handler.cpp \
- interfaces/node.cpp \
logging.cpp \
random.cpp \
rpc/protocol.cpp \