aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2017-11-06 19:12:47 +0100
committerJames Hilliard <james.hilliard1@gmail.com>2018-10-09 03:36:14 -0600
commit9dcf6c0dfec51f2a49edef537f377422d6dbdceb (patch)
tree68628f5648acc166e1bdbd5f3cfbe0cec5caa8d1 /src/Makefile.am
parent1d1417430c829a0c21bf5a2fe4a5b2f592a9423f (diff)
downloadbitcoin-9dcf6c0dfec51f2a49edef537f377422d6dbdceb.tar.xz
build: Add --disable-bip70 configure option
This patch adds a --disable-bip70 configure option that disables BIP70 payment request support. When disabled, this removes the dependency of the GUI on OpenSSL and Protobuf.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7a2e9fa5e8..6141919007 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -587,9 +587,11 @@ if HARDEN
$(AM_V_at) READELF=$(READELF) OBJDUMP=$(OBJDUMP) $(top_srcdir)/contrib/devtools/security-check.py < $(bin_PROGRAMS)
endif
+if ENABLE_BIP70
%.pb.cc %.pb.h: %.proto
@test -f $(PROTOC)
$(AM_V_GEN) $(PROTOC) --cpp_out=$(@D) --proto_path=$(<D) $<
+endif
if EMBEDDED_LEVELDB
include Makefile.leveldb.include