aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKarl-Johan Alm <karljohan-alm@garage.co.jp>2018-03-26 18:36:17 +0900
committerKarl-Johan Alm <karljohan-alm@garage.co.jp>2018-06-12 16:05:20 +0900
commit98b18132308e9524efc3364500770341c666ac90 (patch)
treeca20145f801c018bfc02765cb81234f5b29faa31 /src/Makefile.am
parent7c32b414b6325743c99fed1208bc53ab0fa1996f (diff)
downloadbitcoin-98b18132308e9524efc3364500770341c666ac90.tar.xz
[build] Tune wildcards for LIBSECP256K1 target
Automake would think the target was out of date every time because e.g. '.deps' was updated.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e03c21f16e..28f1fdae00 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -53,7 +53,7 @@ LIBBITCOIN_CRYPTO_AVX2 = crypto/libbitcoin_crypto_avx2.a
LIBBITCOIN_CRYPTO += $(LIBBITCOIN_CRYPTO_AVX2)
endif
-$(LIBSECP256K1): $(wildcard secp256k1/src/*) $(wildcard secp256k1/include/*)
+$(LIBSECP256K1): $(wildcard secp256k1/src/*.h) $(wildcard secp256k1/src/*.c) $(wildcard secp256k1/include/*)
$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
# Make is not made aware of per-object dependencies to avoid limiting building parallelization