aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2014-12-25 11:43:52 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2018-09-13 11:48:23 +0000
commit92af71cea92f8a5185b44e63684b87da9d7ad8a8 (patch)
tree865d35e089d20374310c824ca96d7c3535d553bb /src/Makefile.am
parent288ddf4ff51cf47a40528207ba5d32775a2b9a6d (diff)
downloadbitcoin-92af71cea92f8a5185b44e63684b87da9d7ad8a8.tar.xz
configure: Make it possible to build only one of bitcoin-cli or bitcoin-tx
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 159812e847..d036085642 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -83,8 +83,11 @@ if BUILD_BITCOIND
bin_PROGRAMS += bitcoind
endif
-if BUILD_BITCOIN_UTILS
- bin_PROGRAMS += bitcoin-cli bitcoin-tx
+if BUILD_BITCOIN_CLI
+ bin_PROGRAMS += bitcoin-cli
+endif
+if BUILD_BITCOIN_TX
+ bin_PROGRAMS += bitcoin-tx
endif
.PHONY: FORCE check-symbols check-security