aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGlenn Willen <gwillen@nerdnet.org>2019-01-08 22:16:50 -0800
committerGlenn Willen <gwillen@nerdnet.org>2019-02-11 12:23:14 -0800
commit81cd9588484cb4f4050ea4e239da0681111795db (patch)
tree33f5789d3f2d831d2bfb4098b57a4dea3ec75aea /src/Makefile.am
parentc734aaa15d924470cec0f17b00ad2e47472b471f (diff)
downloadbitcoin-81cd9588484cb4f4050ea4e239da0681111795db.tar.xz
Factor BroadcastTransaction out of sendrawtransaction
Factor out a new BroadcastTransaction function, performing the core work of the sendrawtransaction rpc, so that it can be used from the GUI code. Move it from src/rpc/ to src/node/.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a57fcb0711..9a87af2efc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -152,6 +152,7 @@ BITCOIN_CORE_H = \
netaddress.h \
netbase.h \
netmessagemaker.h \
+ node/transaction.h \
noui.h \
optional.h \
outputtype.h \
@@ -255,6 +256,7 @@ libbitcoin_server_a_SOURCES = \
miner.cpp \
net.cpp \
net_processing.cpp \
+ node/transaction.cpp \
noui.cpp \
outputtype.cpp \
policy/fees.cpp \