aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Posen <jim.posen@gmail.com>2018-08-24 14:48:23 -0700
committerJim Posen <jim.posen@gmail.com>2018-11-05 09:25:15 -0800
commit4fb789e9b2ffdf48fd50293b3982b3fce4d5fbdf (patch)
tree24f14fbfe6b2079e3dbc0952d72477431f679535 /src/Makefile.am
parent6b8d0a2164b30eab76e7bccb1ffb056a10fba406 (diff)
downloadbitcoin-4fb789e9b2ffdf48fd50293b3982b3fce4d5fbdf.tar.xz
Extract CSipHasher to it's own file in crypto/ directory.
This is a move-only commit with the exception of changes to includes.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 703304cebd..662c8bb4d8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -321,7 +321,9 @@ crypto_libbitcoin_crypto_base_a_SOURCES = \
crypto/sha256.cpp \
crypto/sha256.h \
crypto/sha512.cpp \
- crypto/sha512.h
+ crypto/sha512.h \
+ crypto/siphash.cpp \
+ crypto/siphash.h
if USE_ASM
crypto_libbitcoin_crypto_base_a_SOURCES += crypto/sha256_sse4.cpp